Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions (Apache Software Foundation Apache Cassandra)

CVE-2025-23015
HIGH 8.8

At a glance

Source
NVD
EPSS
EPSS 1.01 % · percentile 63 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Weaknesses (CWE)

  • CWE-267 — Privilege Defined With Unsafe Actions

References

Scores

VersionScoreVectorScored by
CVSS 3.1HIGH 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HCISA-ADP
CVSS 3.1HIGH 8.8CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HNVD · 134c704f-9b21-4f2e-91b3-4a467353bcc0 (Secondary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Cassandraaffected 3.0.0 ≤ 3.0.30 ; affected 3.1.0 ≤ 3.11.17 ; affected 4.0.0 ≤ 4.0.15 ; affected 4.1.0 ≤ 4.1.7 ; affected 5.0.0 ≤ 5.0.2

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD