GHSA-wmcc-9vch-jmx4
Apache Cassandra: User with MODIFY permission on ALL KEYSPACES can escalate privileges to superuser via unsafe actions
At a glance
- Published
- Updated
- CVE
- CVE-2025-23015
- Aliases
- BIT-cassandra-2025-23015
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Description
Privilege Defined With Unsafe Actions vulnerability in Apache Cassandra. An user with MODIFY permission ON ALL KEYSPACES can escalate privileges to superuser within a targeted Cassandra cluster via unsafe actions to a system resource. Operators granting data MODIFY permission on all keyspaces on affected versions should review data access rules for potential breaches. This issue affects Apache Cassandra through 3.0.30, 3.11.17, 4.0.15, 4.1.7, 5.0.2. Users are recommended to upgrade to versions 3.0.31, 3.11.18, 4.0.16, 4.1.8, 5.0.3, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.cassandra:cassandra-all | introduced 5.0-alpha1, fixed 5.0.3 |
| Maven · org.apache.cassandra:cassandra-all | introduced 4.1-alpha1, fixed 4.1.8 |
| Maven · org.apache.cassandra:cassandra-all | introduced 4.0-alpha1, fixed 4.0.16 |
| Maven · org.apache.cassandra:cassandra-all | introduced 3.1, fixed 3.11.18 |
| Maven · org.apache.cassandra:cassandra-all | introduced 0, fixed 3.0.31 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-23015 ADVISORY
- https://github.com/apache/cassandra/commit/6207a305ba2b0cebc3241e00a843ab5dbf86d2ed WEB
- https://github.com/apache/cassandra/commit/f33267c8fae6d71166886efc3e7ddda4114ebeef WEB
- https://github.com/apache/cassandra PACKAGE
- https://lists.apache.org/thread/jmks4msbgkl65ssg69x728sv1m0hwz3s WEB
- https://security.netapp.com/advisory/ntap-20250214-0006 WEB
- http://www.openwall.com/lists/oss-security/2025/02/03/2 WEB
- http://www.openwall.com/lists/oss-security/2025/02/11/1 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |