Apache Camel issue on ExchangeCreatedEvent (Apache Software Foundation Apache Camel)

CVE-2024-22371
LOW 2.9

At a glance

Source
NVD
EPSS
EPSS 0.69 % · percentile 53 ()
State
PUBLISHED
Published
Updated
Assigner
apache
NVD status
Analyzed

Description

Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.

Weaknesses (CWE)

  • CWE-922 — Insecure Storage of Sensitive Information

References

Scores

VersionScoreVectorScored by
CVSS 3.1LOW 2.9CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:Napache
CVSS 3.1LOW 2.9CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NNVD · security@apache.org (Secondary)
CVSS 3.1HIGH 7.5CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NNVD · nvd@nist.gov (Primary)

Advisories

European references

Affected configurations (NVD CPE)

Affected products

ProductVersions
Apache Software Foundation · Apache Camelunaffected 1.x ≤ 1.6.0 ; affected 3.21.x ≤ 3.21.3 ; affected 3.22.x ≤ 3.22.0 ; affected 4.0.x ≤ 4.0.3 ; affected 4.x ≤ 4.3.0

Sources

SourceLicence
CVE List (CVEProject cvelistV5)CVE Program Terms of Use
EPSS (FIRST.org)FIRST — attribution requested
ENISA EUVDENISA — reproduction authorised, source acknowledged
NVD (NIST) via fkie-cad/nvd-json-data-feedsPublic domain — this product uses data from the NVD API but is not endorsed or certified by the NVD