GHSA-qpxm-689r-3849
Apache Camel data exposure vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2024-22371
- CVSS_V3
- CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel. This issue affects Apache Camel: from 3.0.0 through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0. Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.camel:camel-core | introduced 3.0.0, fixed 3.21.4 |
| Maven · org.apache.camel:camel-core | introduced 3.22.0, fixed 3.22.1 |
| Maven · org.apache.camel:camel-core | introduced 4.0.0, fixed 4.0.4 |
| Maven · org.apache.camel:camel-core | introduced 4.1.0, fixed 4.4.0 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2024-22371 ADVISORY
- https://camel.apache.org/security/CVE-2024-22371.html WEB
- https://github.com/apache/camel PACKAGE
- https://issues.apache.org/jira/browse/CAMEL-20305 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |