Apache Batik prior to 1.16 allows RCE via scripting (Apache Software Foundation Apache XML Graphics)
En bref
- Source
- NVD
- EPSS
- EPSS 3.36 % · centile 89 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- apache
- Statut NVD
- Modified
Rechercher sur…
Description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.
Faiblesses (CWE)
- CWE-918 — Falsification de requête côté serveur (SSRF)
Références
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-rwqr-m72q-v6cm — Untrusted code execution in Apache XML Graphics Batik
Références européennes
- ENISA EUVD · EUVD-2022-7161
- GCVE · GCVE-0-2022-42890
Avis du CERT-FR
- CERTFR-2025-AVI-0661 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0324 — Multiples vulnérabilités dans Oracle Systems · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0567 — Multiples vulnérabilités dans Oracle WebLogic · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0276 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:apache:batik:*:*:*:*:*:*:*:*≥ 1.0 < 1.16cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
Produits affectés
| Produit | Versions |
|---|---|
| Apache Software Foundation · Apache XML Graphics | affected Batik ≤ 1.15 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |