Apache Batik prior to 1.16 allows RCE via scripting (Apache Software Foundation Apache XML Graphics)
At a glance
- Source
- NVD
- EPSS
- EPSS 3.36 % · percentile 89 ()
- State
- PUBLISHED
- Published
- Updated
- Assigner
- apache
- NVD status
- Modified
Description
A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.
Weaknesses (CWE)
- CWE-918 — Server-Side Request Forgery
References
Scores
| Version | Score | Vector | Scored by |
|---|---|---|---|
| CVSS 3.1 | HIGH 7.5 | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N | NVD · nvd@nist.gov (Primary) |
Advisories
- GHSA-rwqr-m72q-v6cm — Untrusted code execution in Apache XML Graphics Batik
European references
- ENISA EUVD · EUVD-2022-7161
- GCVE · GCVE-0-2022-42890
CERT-FR advisories
- CERTFR-2025-AVI-0661 — Multiples vulnérabilités dans les produits Splunk · cert.ssi.gouv.fr
- CERTFR-2024-AVI-0324 — Multiples vulnérabilités dans Oracle Systems · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0567 — Multiples vulnérabilités dans Oracle WebLogic · cert.ssi.gouv.fr
- CERTFR-2023-AVI-0276 — Multiples vulnérabilités dans les produits IBM · cert.ssi.gouv.fr
Affected configurations (NVD CPE)
cpe:2.3:a:apache:batik:*:*:*:*:*:*:*:*≥ 1.0 < 1.16cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*
Affected products
| Product | Versions |
|---|---|
| Apache Software Foundation · Apache XML Graphics | affected Batik ≤ 1.15 |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |