CVE-2018-1000079
MEDIUM 5.5
En bref
- Source
- NVD
- EPSS
- EPSS 2.78 % · centile 86 ()
- État
- PUBLISHED
- Publiée
- Mise à jour
- Attribuée par
- mitre
- Statut NVD
- Modified
Description
RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.
Faiblesses (CWE)
- CWE-22 — Traversée de répertoire
Références
- https://www.debian.org/security/2018/dsa-4219
- https://usn.ubuntu.com/3621-1/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db921099
- https://access.redhat.com/errata/RHSA-2018:3730
- https://access.redhat.com/errata/RHSA-2018:3731
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2018/dsa-4259
- https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241dd759
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663
Scores
| Version | Score | Vecteur | Évalué par |
|---|---|---|---|
| CVSS 3.0 | MEDIUM 5.5 | CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N | NVD · nvd@nist.gov (Primary) |
| CVSS 2.0 | MEDIUM 4.3 | AV:N/AC:M/Au:N/C:N/I:P/A:N | NVD · nvd@nist.gov (Primary) |
Avis
- GHSA-8qxg-mff5-j3wc — RubyGems Path Traversal vulnerability
Références européennes
- ENISA EUVD · EUVD-2022-3218
- GCVE · GCVE-0-2018-1000079
Avis du CERT-FR
- CERTFR-2025-AVI-0969 — Multiples vulnérabilités dans les produits VMware · cert.ssi.gouv.fr
- CERTFR-2022-AVI-267 — Multiples vulnérabilités dans Juniper Networks Junos Space · cert.ssi.gouv.fr
Configurations affectées (CPE NVD)
cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:*≤ 2.2.9cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:*≤ 2.3.6cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:*≤ 2.4.3cpe:2.3:a:rubygems:rubygems:*:*:*:*:*:*:*:*≤ 2.5.0
Produits affectés
| Produit | Versions |
|---|---|
| affected n/a |
Sources
| Source | Licence |
|---|---|
| CVE List (CVEProject cvelistV5) | CVE Program Terms of Use |
| EPSS (FIRST.org) | FIRST — attribution requested |
| ENISA EUVD | ENISA — reproduction authorised, source acknowledged |
| CERT-FR (ANSSI) | Licence Ouverte / Etalab 2.0 |
| NVD (NIST) via fkie-cad/nvd-json-data-feeds | Public domain — this product uses data from the NVD API but is not endorsed or certified by the NVD |