GHSA-8qxg-mff5-j3wc

RubyGems Path Traversal vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2018-1000079
CVSS_V3
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem writing to arbitrary filesystem locations during installation. This attack appears to be exploitable via installation of a malicious gem. This vulnerability is fixed in 2.7.6.

Paquets affectés

PaquetVersions
RubyGems · rubygems-updateintroduced 0, fixed 2.7.6
Maven · org.jruby:jruby-stdlibintroduced 0, fixed 9.1.16.0

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database