PYSEC-2026-454

pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode

At a glance

Published
Updated
CVE
CVE-2025-12762
Aliases
GHSA-w2p4-p4rh-qcm3
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Description

pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 9.10

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database