PYSEC-2026-454
pgAdmin4 vulnerable to Remote Code Execution (RCE) when running in server mode
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-12762
- Alias
- GHSA-w2p4-p4rh-qcm3
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
Description
pgAdmin versions up to 9.9 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.10 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-12762 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9320 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/1d397395f75320ca1d4ed5e9ca721c603415e836 WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-w2p4-p4rh-qcm3 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |