PYSEC-2026-1776

pgAdmin 4 has command injection vulnerability on Windows systems

At a glance

Published
Updated
CVE
CVE-2025-12763
Aliases
GHSA-rm79-x4g6-hvg5
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H

Description

pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.

Affected packages

PackageVersions
PyPI · pgadmin4introduced 0, fixed 9.10

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database