PYSEC-2026-1776
pgAdmin 4 has command injection vulnerability on Windows systems
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2025-12763
- Alias
- GHSA-rm79-x4g6-hvg5
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
Description
pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · pgadmin4 | introduced 0, fixed 9.10 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2025-12763 ADVISORY
- https://github.com/pgadmin-org/pgadmin4/issues/9323 WEB
- https://github.com/pgadmin-org/pgadmin4/commit/e374edc69239b3e02ecde895e27d9f9e488b87ee WEB
- https://github.com/pgadmin-org/pgadmin4 PACKAGE
- https://pypi.org/project/pgadmin4 PACKAGE
- https://github.com/advisories/GHSA-rm79-x4g6-hvg5 ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |