PYSEC-2026-1140
Apache Airflow Spark Provider vulnerable to improper input validation
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-28710
- Alias
- GHSA-ffj9-4crc-q7wf
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Description
Apache Software Foundation Apache Airflow Spark Provider before 4.0.1 is vulnerable to improper input validation because the host and schema of JDBC Hook can contain `/` and `?` which is used to denote the end of the field.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · apache-airflow-providers-apache-spark | introduced 0, fixed 4.0.1 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-28710 ADVISORY
- https://github.com/apache/airflow/pull/30223 WEB
- https://github.com/apache/airflow PACKAGE
- https://lists.apache.org/thread/lb9w9114ow00h2nkn8bjm106v5x1p1d2 WEB
- http://www.openwall.com/lists/oss-security/2023/04/07/3 WEB
- https://pypi.org/project/apache-airflow-providers-apache-spark PACKAGE
- https://github.com/advisories/GHSA-ffj9-4crc-q7wf ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |