PYSEC-2026-1140

Apache Airflow Spark Provider vulnerable to improper input validation

At a glance

Published
Updated
CVE
CVE-2023-28710
Aliases
GHSA-ffj9-4crc-q7wf
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Description

Apache Software Foundation Apache Airflow Spark Provider before 4.0.1 is vulnerable to improper input validation because the host and schema of JDBC Hook can contain `/` and `?` which is used to denote the end of the field.

Affected packages

PackageVersions
PyPI · apache-airflow-providers-apache-sparkintroduced 0, fixed 4.0.1

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database