PYSEC-2020-206
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2019-14905
- Alias
- GHSA-frxj-5j27-f8rf
Description
A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · ansible | introduced 2.7.0, fixed 2.7.16, introduced 2.8.0, fixed 2.8.8, introduced 2.9.0, fixed 2.9.3 |
Références
- https://access.redhat.com/errata/RHSA-2020:0218 ADVISORY
- https://access.redhat.com/errata/RHSA-2020:0216 ADVISORY
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5BNCYPQ4BY5QHBCJOAOPANB5FHATW2BR/ WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-14905 REPORT
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html WEB
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html WEB
- https://github.com/advisories/GHSA-frxj-5j27-f8rf ADVISORY
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — PyPA Advisory Database |