PYSEC-2020-206

At a glance

Published
Updated
CVE
CVE-2019-14905
Aliases
GHSA-frxj-5j27-f8rf

Description

A vulnerability was found in Ansible Engine versions 2.9.x before 2.9.3, 2.8.x before 2.8.8, 2.7.x before 2.7.16 and earlier, where in Ansible's nxos_file_copy module can be used to copy files to a flash or bootflash on NXOS devices. Malicious code could craft the filename parameter to perform OS command injections. This could result in a loss of confidentiality of the system among other issues.

Affected packages

PackageVersions
PyPI · ansibleintroduced 2.7.0, fixed 2.7.16, introduced 2.8.0, fixed 2.8.8, introduced 2.9.0, fixed 2.9.3

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database