PYSEC-2018-37

At a glance

Published
Updated
CVE
CVE-2016-8614
Aliases
GHSA-cmwx-9m2h-x7v4

Description

A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

Affected packages

PackageVersions
PyPI · ansibleintroduced 0, fixed 2.2.0.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — PyPA Advisory Database