GHSA-x7m3-jprg-wc5g

Gevent allows remote attacker to escalate privileges

At a glance

Published
Updated
CVE
CVE-2023-41419
Aliases
PYSEC-2023-177
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.

Affected packages

PackageVersions
PyPI · geventintroduced 0, fixed 23.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database