GHSA-x7m3-jprg-wc5g
Gevent allows remote attacker to escalate privileges
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-41419
- Alias
- PYSEC-2023-177
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
An issue in Gevent before version 23.9.0 allows a remote attacker to escalate privileges via a crafted script to the WSGIServer component.
Paquets affectés
| Paquet | Versions |
|---|---|
| PyPI · gevent | introduced 0, fixed 23.9.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-41419 ADVISORY
- https://github.com/gevent/gevent/issues/1989 WEB
- https://github.com/gevent/gevent/commit/2f53c851eaf926767fbac62385615efd4886221c WEB
- https://github.com/gevent/gevent PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/gevent/PYSEC-2023-177.yaml WEB
- https://lists.debian.org/debian-lts-announce/2025/11/msg00020.html WEB
- http://www.gevent.org/changelog.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |