GHSA-x3pr-fcgm-wjgc
Subversion Plugin stored XSS vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2020-2111
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Description
Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability. Subversion Plugin 2.13.1 escapes the affected part of the error message.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.jenkins-ci.plugins:subversion | introduced 0, fixed 2.13.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-2111 ADVISORY
- https://github.com/jenkinsci/subversion-plugin/commit/545ca52f6de9af7541621bbea716ead449cd2b98 WEB
- https://github.com/jenkinsci/subversion-plugin PACKAGE
- https://jenkins.io/security/advisory/2020-02-12/#SECURITY-1725 WEB
- http://www.openwall.com/lists/oss-security/2020/02/12/3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |