GHSA-x3pr-fcgm-wjgc

Subversion Plugin stored XSS vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2020-2111
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Description

Jenkins Subversion Plugin 2.13.0 and earlier does not escape the error message for the Project Repository Base URL field form validation, resulting in a stored cross-site scripting vulnerability. Subversion Plugin 2.13.1 escapes the affected part of the error message.

Paquets affectés

PaquetVersions
Maven · org.jenkins-ci.plugins:subversionintroduced 0, fixed 2.13.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database