GHSA-wxqp-jwc9-g39x
Drupal Core Access bypass vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2020-13665
- Aliases
- BIT-drupal-2020-13665
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
Access bypass vulnerability in Drupal Core allows JSON:API when JSON:API is in read/write mode. Only sites that have the read_only set to FALSE under jsonapi.settings config are vulnerable. This issue affects: Drupal Drupal Core 8.8.x versions prior to 8.8.8; 8.9.x versions prior to 8.9.1; 9.0.x versions prior to 9.0.1.
Affected packages
| Package | Versions |
|---|---|
| Packagist · drupal/core | introduced 8.8.0, fixed 8.8.8 |
| Packagist · drupal/core | introduced 8.9.0, fixed 8.9.1 |
| Packagist · drupal/core | introduced 9.0.0, fixed 9.0.1 |
| Packagist · drupal/drupal | introduced 8.8.0, fixed 8.8.8 |
| Packagist · drupal/drupal | introduced 8.9.0, fixed 8.9.1 |
| Packagist · drupal/drupal | introduced 9.0.0, fixed 9.0.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-13665 ADVISORY
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2020-13665.yaml WEB
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2020-13665.yaml WEB
- https://github.com/drupal/core PACKAGE
- https://www.drupal.org/sa-core-2020-006 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |