GHSA-wjc4-73q6-gv3m
plotly.js prototype pollution vulnerability
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-46308
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.
Paquets affectés
| Paquet | Versions |
|---|---|
| Packagist · plotly/plotly.js | introduced 0, fixed 2.25.2 |
| npm · plotly.js | introduced 0, fixed 2.25.2 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-46308 ADVISORY
- https://github.com/plotly/plotly.R/issues/2463 WEB
- https://github.com/plotly/plotly.js/commit/02498404c8ad7a3395191e65694fb142a37b0fe9 WEB
- https://github.com/plotly/plotly.js/commit/5efd2a1f07a418b230a5626fc6c1c7929c47949d WEB
- https://github.com/plotly/plotly.js PACKAGE
- https://github.com/plotly/plotly.js/releases/tag/v2.25.2 WEB
- https://plotly.com/javascript WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |