GHSA-wjc4-73q6-gv3m

plotly.js prototype pollution vulnerability

At a glance

Published
Updated
CVE
CVE-2023-46308
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In Plotly plotly.js before 2.25.2, plot API calls have a risk of __proto__ being polluted in expandObjectPaths or nestedProperty.

Affected packages

PackageVersions
Packagist · plotly/plotly.jsintroduced 0, fixed 2.25.2
npm · plotly.jsintroduced 0, fixed 2.25.2

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database