GHSA-w94p-6mhw-4qxw
Improper Access Control in Elasticsearch
At a glance
- Published
- Updated
- CVE
- CVE-2015-1427
Description
The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to bypass the sandbox protection mechanism and execute arbitrary shell commands via a crafted script.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.elasticsearch:elasticsearch | introduced 0, fixed 1.3.8 |
| Maven · org.elasticsearch:elasticsearch | introduced 1.4.0, fixed 1.4.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1427 ADVISORY
- https://access.redhat.com/errata/RHSA-2017:0868 WEB
- https://exchange.xforce.ibmcloud.com/vulnerabilities/100850 WEB
- https://www.elastic.co/community/security WEB
- http://packetstormsecurity.com/files/130368/Elasticsearch-1.3.7-1.4.2-Sandbox-Escape-Command-Execution.html WEB
- http://packetstormsecurity.com/files/130784/ElasticSearch-Unauthenticated-Remote-Code-Execution.html WEB
- http://www.elasticsearch.com/blog/elasticsearch-1-4-3-1-3-8-released WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |