GHSA-w94p-6mhw-4qxw

Improper Access Control in Elasticsearch

En bref

Publiée
Mise à jour
CVE
CVE-2015-1427

Description

The Groovy scripting engine in Elasticsearch before 1.3.8 and 1.4.x before 1.4.3 allows remote attackers to bypass the sandbox protection mechanism and execute arbitrary shell commands via a crafted script.

Paquets affectés

PaquetVersions
Maven · org.elasticsearch:elasticsearchintroduced 0, fixed 1.3.8
Maven · org.elasticsearch:elasticsearchintroduced 1.4.0, fixed 1.4.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database