GHSA-vwxj-6m5m-rrvh
The REST Plugin in Apache Struts is using an outdated XStream library
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2017-9793
- CVSS_V3
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
The REST Plugin in Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.apache.struts:struts2-rest-plugin | introduced 0, fixed 2.3.34 |
| Maven · org.apache.struts:struts2-rest-plugin | introduced 2.5.0, fixed 2.5.13 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2017-9793 ADVISORY
- https://github.com/advisories/GHSA-vwxj-6m5m-rrvh ADVISORY
- https://security.netapp.com/advisory/ntap-20180629-0001 WEB
- https://struts.apache.org/docs/s2-051.html WEB
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20170907-struts2 WEB
- http://www.brocade.com/content/dam/common/documents/content-types/security-bulletin/brocade-security-advisory-2017-429.htm WEB
- http://www.oracle.com/technetwork/security-advisory/alert-cve-2017-9805-3889403.html WEB
- http://www.securityfocus.com/bid/100611 WEB
- http://www.securitytracker.com/id/1039262 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |