GHSA-vwxj-6m5m-rrvh

The REST Plugin in Apache Struts is using an outdated XStream library

At a glance

Published
Updated
CVE
CVE-2017-9793
CVSS_V3
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

The REST Plugin in Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.

Affected packages

PackageVersions
Maven · org.apache.struts:struts2-rest-pluginintroduced 0, fixed 2.3.34
Maven · org.apache.struts:struts2-rest-pluginintroduced 2.5.0, fixed 2.5.13

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database