GHSA-v49j-62m6-pgrr

Payload: SQL Injection in SQLite and Postgres

En bref

Publiée
Mise à jour
CVE
CVE-2026-105845
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

### Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (`@payloadcms/mongodb`). ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.

Paquets affectés

PaquetVersions
npm · payloadintroduced 3.0.0, fixed 3.88.0
npm · payloadintroduced 4.0.0-canary.0, fixed 4.0.0-canary.27

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database