GHSA-v49j-62m6-pgrr
Payload: SQL Injection in SQLite and Postgres
At a glance
- Published
- Updated
- CVE
- CVE-2026-105845
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
### Impact A user can submit a request that exploits a SQL Injection vulnerability in Payload. You are affected if: - You use an affected Payload version. - Untrusted users can query readable collections using dynamic filters or joins. You are not affected if you use MongoDB (`@payloadcms/mongodb`). ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27`. ### Workarounds Upgrading to a patched version is recommended. Until you can upgrade, restrict untrusted users from supplying dynamic query filters or join parameters and limit read access to affected collections.
Affected packages
| Package | Versions |
|---|---|
| npm · payload | introduced 3.0.0, fixed 3.88.0 |
| npm · payload | introduced 4.0.0-canary.0, fixed 4.0.0-canary.27 |
References
- https://github.com/payloadcms/payload/security/advisories/GHSA-v49j-62m6-pgrr WEB
- https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a WEB
- https://github.com/payloadcms/payload PACKAGE
- https://github.com/payloadcms/payload/releases/tag/v3.88.0 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |