GHSA-rmpj-7c96-mrg8

Apache Hadoop heap overflow before v2.10.2, v3.2.3, v3.3.2

En bref

Publiée
Mise à jour
CVE
CVE-2021-37404
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Paquets affectés

PaquetVersions
Maven · org.apache.hadoop:hadoop-commonintroduced 3.3.0, fixed 3.3.2
Maven · org.apache.hadoop:hadoop-commonintroduced 3.0.0, fixed 3.2.3
Maven · org.apache.hadoop:hadoop-commonintroduced 0, fixed 2.10.2

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database