GHSA-rmpj-7c96-mrg8
Apache Hadoop heap overflow before v2.10.2, v3.2.3, v3.3.2
At a glance
- Published
- Updated
- CVE
- CVE-2021-37404
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.hadoop:hadoop-common | introduced 3.3.0, fixed 3.3.2 |
| Maven · org.apache.hadoop:hadoop-common | introduced 3.0.0, fixed 3.2.3 |
| Maven · org.apache.hadoop:hadoop-common | introduced 0, fixed 2.10.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-37404 ADVISORY
- https://github.com/apache/hadoop PACKAGE
- https://lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo WEB
- https://security.netapp.com/advisory/ntap-20220715-0007 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |