GHSA-rhrv-645h-fjfh
Apache Avro Java SDK vulnerable to Improper Input Validation
At a glance
- Published
- Updated
- CVE
- CVE-2023-39410
- Aliases
- PYSEC-2023-188
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.avro:avro | introduced 0, fixed 1.11.3 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-39410 ADVISORY
- https://github.com/apache/avro/commit/a12a7e44ddbe060c3dc731863cad5c15f9267828 WEB
- https://github.com/apache/avro PACKAGE
- https://github.com/pypa/advisory-database/tree/main/vulns/avro/PYSEC-2023-188.yaml WEB
- https://issues.apache.org/jira/browse/AVRO-3819 WEB
- https://lists.apache.org/thread/q142wj99cwdd0jo5lvdoxzoymlqyjdds WEB
- https://security.netapp.com/advisory/ntap-20240621-0006 WEB
- https://www.openwall.com/lists/oss-security/2023/09/29/6 WEB
- http://www.openwall.com/lists/oss-security/2023/09/29/6 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |