GHSA-rhrv-645h-fjfh

Apache Avro Java SDK vulnerable to Improper Input Validation

En bref

Publiée
Mise à jour
CVE
CVE-2023-39410
Alias
PYSEC-2023-188
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Description

When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.

Paquets affectés

PaquetVersions
Maven · org.apache.avro:avrointroduced 0, fixed 1.11.3

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database