GHSA-rg58-xhh7-mqjw

Apache Struts has a Denial of Service vulnerability

En bref

Publiée
Mise à jour
CVE
CVE-2025-66675
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

Description

Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.

Paquets affectés

PaquetVersions
Maven · org.apache.struts:struts2-coreintroduced 2.0.0, fixed 6.8.0
Maven · org.apache.struts:struts2-coreintroduced 7.0.0, fixed 7.1.1

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database