GHSA-rg58-xhh7-mqjw
Apache Struts has a Denial of Service vulnerability
At a glance
- Published
- Updated
- CVE
- CVE-2025-66675
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Description
Denial of Service vulnerability in Apache Struts, file leak in multipart request processing causes disk exhaustion. This issue affects Apache Struts: from 2.0.0 through 6.7.4, from 7.0.0 through 7.0.3. Users are recommended to upgrade to version 6.8.0 or 7.1.1, which fixes the issue.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.apache.struts:struts2-core | introduced 2.0.0, fixed 6.8.0 |
| Maven · org.apache.struts:struts2-core | introduced 7.0.0, fixed 7.1.1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-66675 ADVISORY
- https://github.com/apache/struts/commit/831568929cfba700f790f6ebe6e335f9f33fb468 WEB
- https://cve.org/CVERecord?id=CVE-2025-64775 WEB
- https://cwiki.apache.org/confluence/display/WW/S2-068 WEB
- https://github.com/apache/struts PACKAGE
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |