GHSA-r6h7-5pq2-j77h

Insufficiently random values in Ansible

En bref

Publiée
Mise à jour
CVE
CVE-2020-10729
Alias
PYSEC-2021-105
CVSS_V3
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
CVSS_V4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Description

A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.

Paquets affectés

PaquetVersions
PyPI · ansibleintroduced 0, fixed 2.9.6

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database