GHSA-r6h7-5pq2-j77h
Insufficiently random values in Ansible
At a glance
- Published
- Updated
- CVE
- CVE-2020-10729
- Aliases
- PYSEC-2021-105
- CVSS_V3
- CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CVSS_V4
- CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Description
A flaw was found in the use of insufficiently random values in Ansible. Two random password lookups of the same length generate the equal value as the template caching action for the same file since no re-evaluation happens. The highest threat from this vulnerability would be that all passwords are exposed at once for the file. This flaw affects Ansible Engine versions before 2.9.6.
Affected packages
| Package | Versions |
|---|---|
| PyPI · ansible | introduced 0, fixed 2.9.6 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2020-10729 ADVISORY
- https://github.com/ansible/ansible/issues/34144 WEB
- https://github.com/ansible/ansible/pull/67429 WEB
- https://github.com/ansible/ansible/commit/c520d70bf4748c8ee6718a7d0d0254051ba1c2e9 WEB
- https://bugzilla.redhat.com/show_bug.cgi?id=1831089 WEB
- https://github.com/advisories/GHSA-r6h7-5pq2-j77h ADVISORY
- https://github.com/ansible/ansible PACKAGE
- https://github.com/ansible/ansible/blob/v2.9.6/changelogs/CHANGELOG-v2.9.rst WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2021-105.yaml WEB
- https://www.debian.org/security/2021/dsa-4950 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |