GHSA-q4m3-2j7h-f7xw

Cross-Site Scripting in jquery

At a glance

Published
Updated
CVE
CVE-2020-7656
Aliases
SNYK-JS-JQUERY-569619
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Description

Versions of `jquery` prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove `<script>` HTML tags that contain a whitespace character, i.e: `</script >`, which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 1.9.0 or later.

Affected packages

PackageVersions
npm · jqueryintroduced 1.2.1, fixed 1.9.0
NuGet · jQueryintroduced 1.2.1, fixed 1.9.0
RubyGems · jquery-railsintroduced 0, fixed 2.2.0
Maven · org.webjars.npm:jqueryintroduced 1.2.1, fixed 1.9.0

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database