GHSA-q4m3-2j7h-f7xw
Cross-Site Scripting in jquery
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2020-7656
- Alias
- SNYK-JS-JQUERY-569619
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
Description
Versions of `jquery` prior to 1.9.0 are vulnerable to Cross-Site Scripting. The load method fails to recognize and remove `<script>` HTML tags that contain a whitespace character, i.e: `</script >`, which results in the enclosed script logic to be executed. This allows attackers to execute arbitrary JavaScript in a victim's browser. ## Recommendation Upgrade to version 1.9.0 or later.
Paquets affectés
| Paquet | Versions |
|---|---|
| npm · jquery | introduced 1.2.1, fixed 1.9.0 |
| NuGet · jQuery | introduced 1.2.1, fixed 1.9.0 |
| RubyGems · jquery-rails | introduced 0, fixed 2.2.0 |
| Maven · org.webjars.npm:jquery | introduced 1.2.1, fixed 1.9.0 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2020-7656 ADVISORY
- https://github.com/jquery/jquery/commit/05531fc4080ae24070930d15ae0cea7ae056457d WEB
- https://github.com/jquery/jquery/commit/606b863edaff29035960e4d813b45d63b8d92876 WEB
- https://github.com/jquery/jquery PACKAGE
- https://github.com/jquery/jquery/blob/9e6393b0bcb52b15313f88141d0bd7dd54227426/src/ajax.js#L203 WEB
- https://github.com/rails/jquery-rails/blob/master/CHANGELOG.md#220-19-january-2013 WEB
- https://github.com/rails/jquery-rails/blob/v2.1.4/vendor/assets/javascripts/jquery.js#L7481 WEB
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/jquery-rails/CVE-2020-7656.yml WEB
- https://security.netapp.com/advisory/ntap-20200528-0001 WEB
- https://snyk.io/vuln/SNYK-JS-JQUERY-569619 WEB
- https://supportportal.juniper.net/s/article/2021-07-Security-Bulletin-Junos-OS-Multiple-J-Web-vulnerabilities-resolved-in-Junos-OS-21-2R1?language=en_US WEB
- https://www.oracle.com/security-alerts/cpujul2022.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |