GHSA-mw3v-mmfw-3x2g
OpenSearch is vulnerable to DoS via complex query_string inputs
At a glance
- Published
- Updated
- CVE
- CVE-2025-9624
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
Description
A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.
Affected packages
| Package | Versions |
|---|---|
| Maven · org.opensearch:opensearch-common | introduced 3.0.0, fixed 3.3.0 |
| Maven · org.opensearch:opensearch-common | introduced 0, fixed 2.19.4 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-9624 ADVISORY
- https://github.com/opensearch-project/OpenSearch/pull/19491 WEB
- https://caverav.cl/posts/opensearch-dos/opensearch-dos WEB
- https://fluidattacks.com/advisories/chick WEB
- https://github.com/opensearch-project/OpenSearch PACKAGE
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.19.4 WEB
- https://github.com/opensearch-project/OpenSearch/releases/tag/3.3.0 WEB
- https://opensearch.org/blog/explore-opensearch-3-3 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |