GHSA-mw3v-mmfw-3x2g

OpenSearch is vulnerable to DoS via complex query_string inputs

En bref

Publiée
Mise à jour
CVE
CVE-2025-9624
CVSS_V4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H

Description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.

Paquets affectés

PaquetVersions
Maven · org.opensearch:opensearch-commonintroduced 3.0.0, fixed 3.3.0
Maven · org.opensearch:opensearch-commonintroduced 0, fixed 2.19.4

Références

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database