GHSA-m5cw-c64p-77h6

CSRF vulnerability in Jenkins Subversion Plugin

At a glance

Published
Updated
CVE
CVE-2022-29048
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Description

Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities. These vulnerabilities allow attackers to connect to an attacker-specified URL.

Affected packages

PackageVersions
Maven · org.jenkins-ci.plugins:subversionintroduced 0, fixed 2.15.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database