GHSA-m5cw-c64p-77h6
CSRF vulnerability in Jenkins Subversion Plugin
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2022-29048
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
Description
Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities. These vulnerabilities allow attackers to connect to an attacker-specified URL.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.plugins:subversion | introduced 0, fixed 2.15.4 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2022-29048 ADVISORY
- https://github.com/jenkinsci/subversion-plugin/commit/882a7d359f6ac73c53d787bff4d62eba837001ea WEB
- https://github.com/jenkinsci/subversion-plugin PACKAGE
- https://support.apple.com/kb/HT213345 WEB
- https://www.jenkins.io/security/advisory/2022-04-12/#SECURITY-2075 WEB
- http://seclists.org/fulldisclosure/2022/Jul/18 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |