GHSA-jchm-fm4q-c2fp
Apache Airflow vulnerable to Privilege Context Switching Error
At a glance
- Published
- Updated
- CVE
- CVE-2023-25754
- Aliases
- BIT-airflow-2023-25754, PYSEC-2023-59
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS_V4
- CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Description
Privilege Context Switching Error vulnerability in Apache Software Foundation Apache Airflow. This issue affects Apache Airflow: before 2.6.0.
Affected packages
| Package | Versions |
|---|---|
| PyPI · apache-airflow | introduced 0, fixed 2.6.0b1 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2023-25754 ADVISORY
- https://github.com/apache/airflow/pull/29506 WEB
- https://github.com/apache/airflow/commit/18347d36e67894604436f3ef47d273532683b473 WEB
- https://github.com/apache/airflow PACKAGE
- https://github.com/apache/airflow/releases/tag/2.6.0 WEB
- https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-59.yaml WEB
- https://lists.apache.org/thread/3y83gr0qb8t49ppfk4fb2yk7md8ltq4v WEB
- https://www.openwall.com/lists/oss-security/2023/05/08/2 WEB
- http://www.openwall.com/lists/oss-security/2023/05/08/2 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |