GHSA-j664-qhh4-hpf8
Cross-site Scripting vulnerability in Jenkins
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-27898
- Alias
- BIT-jenkins-2023-27898
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Description
Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.jenkins-ci.main:jenkins-core | introduced 2.376, fixed 2.394 |
| Maven · org.jenkins-ci.main:jenkins-core | introduced 0, fixed 2.375.4 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-27898 ADVISORY
- https://github.com/jenkinsci/jenkins/commit/59ac866d9946d7c296023da0ea78baafd4cf71eb WEB
- https://www.jenkins.io/security/advisory/2023-03-08/#SECURITY-3037 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |