GHSA-j664-qhh4-hpf8

Cross-site Scripting vulnerability in Jenkins

At a glance

Published
Updated
CVE
CVE-2023-27898
Aliases
BIT-jenkins-2023-27898
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Description

Jenkins 2.270 through 2.393 (both inclusive), LTS 2.277.1 through 2.375.3 (both inclusive) does not escape the Jenkins version a plugin depends on when rendering the error message stating its incompatibility with the current version of Jenkins, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide plugins to the configured update sites and have this message shown by Jenkins instances.

Affected packages

PackageVersions
Maven · org.jenkins-ci.main:jenkins-coreintroduced 2.376, fixed 2.394
Maven · org.jenkins-ci.main:jenkins-coreintroduced 0, fixed 2.375.4

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database