GHSA-g5h3-w546-pj7f
Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry
En bref
- Publiée
- Mise à jour
- CVE
- CVE-2023-20873
- CVSS_V3
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Paquets affectés
| Paquet | Versions |
|---|---|
| Maven · org.springframework.boot:spring-boot-actuator-autoconfigure | introduced 3.0.0, fixed 3.0.6 |
| Maven · org.springframework.boot:spring-boot-actuator-autoconfigure | introduced 2.7.0, fixed 2.7.11 |
| Maven · org.springframework.boot:spring-boot-actuator-autoconfigure | introduced 2.6.0, fixed 2.6.15 |
| Maven · org.springframework.boot:spring-boot-actuator-autoconfigure | introduced 0, fixed 2.5.15 |
Références
- https://nvd.nist.gov/vuln/detail/CVE-2023-20873 ADVISORY
- https://github.com/spring-projects/spring-boot/commit/32444fed4b51cc58dc908467f706102d7f0bfc15 WEB
- https://github.com/spring-projects/spring-boot/commit/3522714c13b47af03bf42e7f2d5994af568cb1a7 WEB
- https://github.com/spring-projects/spring-boot PACKAGE
- https://github.com/spring-projects/spring-boot/releases/tag/v2.5.15 WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v2.6.15 WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v2.7.11 WEB
- https://github.com/spring-projects/spring-boot/releases/tag/v3.0.6 WEB
- https://security.netapp.com/advisory/ntap-20230601-0009 WEB
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now WEB
- https://spring.io/security/cve-2023-20873 WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |