GHSA-g5h3-w546-pj7f

Spring Boot Security Bypass with Wildcard Pattern Matching on Cloud Foundry

At a glance

Published
Updated
CVE
CVE-2023-20873
CVSS_V3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Description

In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.

Affected packages

PackageVersions
Maven · org.springframework.boot:spring-boot-actuator-autoconfigureintroduced 3.0.0, fixed 3.0.6
Maven · org.springframework.boot:spring-boot-actuator-autoconfigureintroduced 2.7.0, fixed 2.7.11
Maven · org.springframework.boot:spring-boot-actuator-autoconfigureintroduced 2.6.0, fixed 2.6.15
Maven · org.springframework.boot:spring-boot-actuator-autoconfigureintroduced 0, fixed 2.5.15

References

Sources

SourceLicence
OSV.devCC-BY 4.0 — GitHub Advisory Database