GHSA-cc3w-r3w8-hfh7
Magento Improper Authorization vulnerability in the customers module
At a glance
- Published
- Updated
- CVE
- CVE-2021-28567
- Aliases
- BIT-magento-2021-28567
- CVSS_V3
- CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
Description
Magento versions 2.4.2 (and earlier), 2.4.1-p1 (and earlier) and 2.3.6-p1 (and earlier) are vulnerable to an Improper Authorization vulnerability in the customers module. Successful exploitation could allow a low-privileged user to modify customer data. Access to the admin console is required for successful exploitation.
Affected packages
| Package | Versions |
|---|---|
| Packagist · magento/community-edition | introduced 2.4.0, fixed 2.4.2-p1 |
| Packagist · magento/community-edition | introduced 0, fixed 2.3.7 |
| Packagist · magento/project-community-edition | introduced 0, last affected 2.0.2 |
References
- https://nvd.nist.gov/vuln/detail/CVE-2021-28567 ADVISORY
- https://github.com/magento/magento2/commit/1bd5cb8c065e44779526c0b044ce19b884707695 WEB
- https://github.com/magento/magento2 PACKAGE
- https://helpx.adobe.com/security/products/magento/apsb21-30.html WEB
Sources
| Source | Licence |
|---|---|
| OSV.dev | CC-BY 4.0 — GitHub Advisory Database |